分类
外匯交易如何獲利

MACD和RSI指标的优化

柱狀圖的計算方法

通达信极品RSI优化操盘指标公式

LC1:= SMA(MACD和RSI指标的优化 C,2,1);
TCRSI:=SMA(MAX(CLOSE-LC1,0),6,1)/SMA(ABS(CLOSE-LC1),6,1)*100;
LC2:= SMA(H,2,1);
THRSI:=SMA(MAX(H-LC2,0),6,1)/SMA(ABS(H-LC2),MACD和RSI指标的优化 6,1)*100;
LC3:= SMA(O,2,1);
TORSI:=SMA(MAX(O-LC3,0),6,1)/SMA(ABS(O-LC3),6,1)*100;
LC4:= SMA(L,2,1);
TLRSI:=SMA(MAX(L-LC4,0),6,1)/SMA(ABS(L-LC4),6,1)*100;
TVAR:=SMA(((10000 * CLOSE) / INDEXC),2,1);
『大盘关联』:=SMA(MAX(((10000 * CLOSE) / INDEXC)-TVAR,0),6,1)/SMA(ABS(((10000 * CLOSE) / INDEXC)-TVAR),6,1)*100;
TTRSI:(TCRSI+TORSI+THRSI+TLRSI+『大盘关联』)/5;
参考线:EMA(EMA(TTRSI,6),5);
中轨: MA(TTRSI,26);
上轨: 中轨+ 2*STD(TTRSI,26),LINETHICK2,COLORFFBB00;
下轨: 中轨- 2*STD(TTRSI,26),LINETHICK2,COLOR00FF00;
底关注:STICKLINE(TTRSI 买关注:STICKLINE(MACD和RSI指标的优化 参考线 顶关注:STICKLINE(TTRSI>=80,100,106,5,0),COLOR00FF00;
卖关注:STICKLINE(参考线>=80,110,116,5,0),COLORFF0000;
STICKLINE(CROSS(参考线,中轨),20,80,2,0),COLOR0000FF;

MACD和RSI指标的优化

. 平均线、MACD、趋势线等趋势性指标,而不要采用像KDJ、RSI等摆动性指标。 第二,交易仓位可适当重一些,资金管理方面可宽松一点,通常首次进场仓位的资金量可为总资金量的30%,甚至更高一点。 第三,必须使用随.

程序化交易系统模型的设计

旱情继续发展 玉米短期偏强

耶伦女王驾临美多头“精神抖擞” 油市“双喜临门”油价大涨

案例分析——程序化交易

美联储再放言论 LMCI不能救黄金于水火

20140122工业品部日评

黄金 开局一改“熊”样 会否昙花一现

20140327工业品部日评

20140113工业品部日评

20140307工业品部日评

程序化交易模型的仿真运行

20140304工业品部日评

20140110农产品日评

20140106农产品日评

20140109农产品日评

20140305工业品部日评

20140307农产品日评

地址:深圳市南山区粤海街道滨海社区海天一路 19、17、18号软件产业基地 4 栋 4 层 407、409 邮编:518054
电话:0755-83410021 传真:0755-83417337 Email:[email protected]

Copyright @ 2007 - 2022 深圳开拓者科技有限公司 All Rights Reserved. 版权所有 未经许可 请勿转载
粤ICP备07044698号

通达信极品RSI优化操盘指标公式

LC1:= SMA(C,2,1);
TCRSI:=SMA(MAX(CLOSE-LC1,0),6,1)/SMA(ABS(CLOSE-LC1),6,1)*100;
LC2:= SMA(H,2,1);
THRSI:=SMA(MAX(H-LC2,0),6,1)/SMA(ABS(H-LC2),6,1)*100;
LC3:= SMA(O,2,1);
TORSI:=SMA(MAX(O-LC3,0),6,1)/SMA(ABS(O-LC3),6,1)*100;
LC4:= SMA(L,2,1);
TLRSI:=SMA(MAX(L-LC4,0),6,1)/SMA(ABS(L-LC4),6,1)*100;
TVAR:=SMA(((10000 * CLOSE) / INDEXC),2,1);
『大盘关联』:=SMA(MAX(((10000 * CLOSE) / INDEXC)-TVAR,0),6,1)/SMA(ABS(((10000 * CLOSE) / INDEXC)-TVAR),6,1)*100;
TTRSI:(TCRSI+TORSI+THRSI+TLRSI+『大盘关联』)/5;
参考线:EMA(EMA(TTRSI,6),5);
中轨: MA(TTRSI,26);
上轨: 中轨+ 2*STD(TTRSI,26),LINETHICK2,COLORFFBB00;
下轨: 中轨- 2*STD(TTRSI,26),LINETHICK2,COLOR00FF00;
底关注:STICKLINE(MACD和RSI指标的优化 TTRSI 买关注:STICKLINE(参考线 顶关注:STICKLINE(TTRSI>=80,100,106,5,0),COLOR00FF00;
卖关注:STICKLINE(参考线>=80,110,116,5,0),COLORFF0000;
STICKLINE(CROSS(参考线,中轨),20,80,2,0),COLOR0000FF;

五分鐘學懂解讀MACD線

MACD 與交叉

MACD 名稱與公式

MACD 全名與計算方法

MACD的五項組件

好了,馬上開始。學MACD要懂得五個項目:參數、MACD線、Signal線、Histogram、零線。如果你想更有專業感,可如下圖稱呼為DIEF線、DEA線、Divergence:

MACD 各線的稱呼

使用上述這些詞彙,會讓行外人更難懂。所以我們可以簡單一些,稱呼為短線、長線,一根根的柱子稱為柱狀便可:

MACD 各線的稱呼

MACD 基本解讀法

我們先不談「參數」,因為對於新手而言,參數是比較複雜的概念。其後的教學文章會談談指標的參數,現在我們先採用MACD最傳統參數—12,26,9。大家先不要嘗試理解這些數字,姑且稱它為MACD(12,26,9)便可。

MACD 傳統參數

傳統上,當MACD短線和長線於零線之上,便代表價格處於升勢

MACD 短線和長線於零線之上

MACD短線和長線於零線之下,便代表價格處於跌勢

MACD 短線和長線於零線之下

黃金交叉 與 死亡交叉

黃金交叉 死亡交叉

傳統入市框架

黃金交叉」意思是當短線升穿長線造好,其後短線跌穿長線平倉;「死亡交叉」則相反,短線跌穿長線造淡,其後短線升穿長線平倉

黃金交叉

死亡交叉

死亡交叉 死亡交叉

「雙牛」「雙熊」訊號

「雙牛」「雙熊」訊號又是什麼東東?在投資世界中,牛代表上升熊代表下跌,所以平常所說的大牛市,就是指大升市;大熊市則指大跌市。

牛市 熊市

所謂「雙牛」其實即是雙重升勢訊號「雙熊」就是雙重跌勢訊號,簡單易明。當MACD兩條線在零線之上,即代表價格處於升勢,如果再出現多一個「黃金交叉」,即是雙重升勢訊號。概念上正是提高買升的準確度,雙重確認

雙牛 雙熊

雙牛訊號

雙熊訊號 雙熊訊號

MACD 柱狀

柱狀圖的計算方法

柱狀圖貌似複雜,猜不透其計算方法,但其實這些柱只不過是短線和長線的「差」,亦即是以短線減去長線的數值去計算出來。

MACD 柱狀計算方法

如果大家腦筋轉得快,可能已經推論出,當柱狀數值由正數變為負數,其實即是出現「死亡交叉」;相反,由負數變為正數,便是出現「黃金交叉」的時候:

MACD 柱狀

MACD 的利用價值

MACD可說是技術分析領域中必學的指標,我個人認為MACD具學習價值的地方,並非由於它的傳統用法特別準,而是因為MACD的用法有許多,單單一個指標已可設計出過千種策略。即使不用作主力分析,亦可用來輔助。因此,利用MACD來培養Trader的策略設計思維,是一個好選擇。最重要的是,MACD的公式和概念具有很高參考價值,將來優化和研創指標亦可參考它,甚至直接以它為根基亦可。

MACD 的價值

MACD 傳統策略已失效